Componize for Alfresco AMPs

Componize for Alfresco is packaged as several standard Alfresco Module Packages (AMPs). Some of the packages are required and others are optional.

Please consult the following list of AMPs and select those that are required and optional for your installation.

Note:

AMPs with names that start with componize-alfresco-* are to be installed in alfresco.war.

AMPs with names that start with componize-share-* are to be installed in share.war.

Required AMPs

Select the AMPs for your specific version of Alfresco.

AMP filename Description
componize-alfresco-community-5.2.g-3.2.2.amp Componize for Alfresco Community 201707 (5.2.g)
componize-alfresco-community-6.1.2-ga-4.0.1.amp Componize for Alfresco Community 6.1.2-ga
componize-alfresco-community-6.2.0-ga-4.1.0.amp Componize for Alfresco Community 6.2.0-ga
componize-alfresco-enterprise-5.2.6-3.3.0.amp Componize for Alfresco Enterprise 5.2.6
componize-alfresco-enterprise-6.1.1.3-4.0.2.amp Componize for Alfresco Enterprise 6.1.1.3
componize-alfresco-enterprise-6.2.1-4.1.1.amp Componize for Alfresco Enterprise 6.2.1
componize-share-community-5.2.f-3.2.2.amp Componize for Alfresco Share Community 201707 (5.2.f)
componize-share-community-6.1.0-RC3-4.0.1.amp Componize for Alfresco Share Community 6.1.0-RC3
componize-share-6.2.0-4.1.0.amp Componize for Alfresco Share Community 6.2.0-ga
componize-share-enterprise-5.2.6-3.3.0.amp Componize for Alfresco Share Enterprise 5.2.6
componize-share-enterprise-6.1.1.1-4.0.2.amp Componize for Alfresco Share Enterprise 6.1.1.1
componize-share-6.2.1-4.1.1.amp Componize for Alfresco Share Enterprise 6.2.1
Select one of the DITA Open Toolkit AMPs.
Note: The DITA Open Toolkit version of your choice can now be installed using the DITA Open Toolkit Server. See: Installing the DITA Open Toolkit Server
AMP filename Description
componize-alfresco-dita-ot-1.8-4.1.0.amp DITA Open Toolkit 1.8.5.

Optional AMPs

The following AMPs are optional and should be installed only when necessary.
Note: Some AMPs also require the installation of 3rd party software.
AMP filename Description
componize-alfresco-ah-formatter-2.2.1.amp Support for the Antenna House XSL Formatter.
Note: The Antenna House XSL Formatter software needs to be installed separately.
componize-fluid-topics-1.0.amp Plugin to connect to a Fluid Topics server.
componize-share-oxygen-webapp-4.1.0.amp oXygen XML Web Author integration for Alfresco Share.
Note: The oXygen XML Web Author WAR file needs to be installed separately.