Installing the Componize for Alfresco AMPs

Perform this task to install the Componize for Alfresco AMPs.

Before installing the Componize for Alfresco AMPs, you must first install Alfresco.
Note: We recommend that you fully test your Alfresco installation before installing the Componize for Alfresco AMPs.
The Componize for Alfresco AMPs are installed using the Module Management Tool (MMT).
  1. Download the Componize AMP files from https://download.componize.com:

    Componize for Alfresco AMPs:

    • componize-alfresco-community-6.2.0-ga-4.1.0.amp
    • componize-alfresco-dita-ot-1.8-4.1.0.amp

    Componize for Alfresco Share AMPs:

    • componize-share-6.2.0-4.1.0.amp
  2. From the Alfresco manager tool, make sure the Tomcat and the PostgreSQL servers are stopped.
  3. If this is not the case, click Stop all.
  4. Note: These steps will remove the previously deployed Web apps.
    Copy these files from the download folder:
    1. All Componize AMPs to be installed in alfresco.war into the installation folder in the subfolder amps.
    2. All Componize AMPs to be installed in share.war into the installation folder in the subfolder amps_share.
  5. Open the command console in the installation folder.
  6. Run the following command: bin/apply_amps.bat -force
  7. Press any key when asked by the console.
    The alfresco.war and share.war files are updated with the Componize for Alfresco AMPs in tomcat/webapps.
  8. From the Alfresco manager tool, click Start all to restart Tomcat and the PostgreSQL servers.
    The Componize for Alfresco modules will be installed and initialized during application startup.